<    March 2017    >
Su Mo Tu We Th Fr Sa  
          1  2  3  4  
 5  6  7  8  9 10 11  
12 13 14 15 16 17 18  
19 20 21 22 23 24 25  
26 27 28 29 30 31
00:32 minimalism joined
02:55 s33se_ joined
05:16 blueness joined
05:27 alacerda_ joined
06:28 volleyper joined
07:50 alacerda_ joined
08:04 blahdodo joined
08:35 volleyper joined
09:31 blueness joined
09:51 fekepp joined
10:03 blueness joined
10:58 rk324 joined
12:06 stwa joined
12:21 shansen joined
12:39 kaiyou joined
12:51 alacerda joined
13:08 Emperor_Earth joined
13:15 czart_ joined
13:59 <tmh1999> jirutka : I was building lua-mpack on x86_64/edge, and have this error : http://tpaste.us/dj5l
14:00 <tmh1999> jirutka : lua5.1 and lua5.2 testing was ok, but failed at lua5.3
14:01 <tmh1999> libmpack doesn't ship lua.h, and they still do --with-lua like thta
14:01 <tmh1999> *that
14:01 <jirutka> hm, it fails even on my system, weird
14:02 <tmh1999> maybe some changes was made from libmpack side
14:03 <tmh1999> seems not, you pushed 6 days ago while libmpack 1.0.4 was in Jan
14:03 <tmh1999> strange
14:03 <jirutka> more probably some change in lua5.3
14:03 <jirutka> but the only change I did recently is keeping liblua.a
14:04 <tmh1999> but I still dont understand the --with-lua ?
14:06 <jirutka> it should not do that
14:06 <jirutka> it’s trying to download luarocks, so something is wrong
14:06 <tmh1999> yeah, the directory --with-lua=$DIR doesnt even exist
14:06 <tmh1999> so the idea is to disable luarocks ? Okay
14:10 <tmh1999> I got it
14:11 <tmh1999> in check() change LUAROCK=/bin/false to LUAROCK=/usr/bin/luarocks-$lver
14:11 <tmh1999> add luarocks as makedepends
14:11 <jirutka> no, it should not invoke luarocks at all
14:11 <tmh1999> but libmpack requires luarocks
14:11 <jirutka> LUAROCKS=/bin/false is intentional
14:12 <jirutka> to install dependencies that we already have…
14:12 <jirutka> it’s just horribly written makefile
14:13 <jirutka> okay, I’ll just patch it, I have no clue why it works differently for 5.3 and it’s hard to untangled it
14:13 <tmh1999> I am getting it with lua5.1 on s390x/edge. Hopefully your patch will fix not just 5.3.
14:14 <tmh1999> jirutka : Thank you :)
14:16 minimalism joined
14:24 <jirutka> tmh1999: you’re welcome
14:24 <jirutka> tmh1999: pushed now
14:24 <tmh1999> kaniini : wow GUI for apk !
14:25 <tmh1999> jirutka : Thanks :)
14:35 blueness joined
14:47 blueness joined
16:22 <scadu> jirutka: https://travis-ci.org/alpinelinux/aports/builds/212478306#L455 seems like another Travis glitch.
16:29 <jirutka> scadu: yeah, probably, I can’t reproduce this error on my machine
16:30 <jirutka> scadu: btw is it needed to use bundled libuv instead of system-provided?
16:45 volleyper joined
17:41 <scadu> jirutka: I am afraid yes. cjdns maintainer uses the older version of libuv and our current version may cause issues I had to fix on my own
18:16 blueness joined
19:36 blueness joined
22:17 _ikke_ joined
22:19 fekepp joined
23:11 Emperor_Earth joined