<     May 2017     >
Su Mo Tu We Th Fr Sa  
    1  2  3  4  5  6  
 7  8  9 10 11 12 13  
14 15 16 17 18 19 20  
21 22 23 24 25 26 27  
28 29 30 31
00:11 czart joined
00:12 mrEngineer joined
00:20 grayhemp joined
00:22 dave0x6d joined
00:29 grayhemp joined
00:37 hackerhercules joined
01:00 jushur joined
01:31 s33se_ joined
01:36 grayhemp_ joined
01:50 atrigent joined
02:03 grayhemp joined
02:07 robru joined
02:09 felixsanz joined
02:20 czart_ joined
02:27 czart__ joined
02:38 k0nsl joined
02:38 k0nsl joined
02:48 emacsoma` joined
02:52 k0nsl joined
02:52 k0nsl joined
02:58 grayhemp joined
03:26 k0nsl joined
03:26 k0nsl joined
03:36 k0nsl joined
03:36 k0nsl joined
04:03 grayhemp joined
04:05 emacsoma` joined
04:45 Nunya joined
04:48 grayhemp_ joined
04:51 grayhemp joined
04:57 k0nsl joined
04:57 k0nsl joined
05:09 greguu joined
05:21 silviof joined
05:25 grayhemp joined
05:28 fabled joined
05:32 czart_ joined
05:53 k0nsl joined
05:53 k0nsl joined
06:02 grayhemp joined
06:23 grayhemp joined
06:31 rnalrd joined
06:37 k0nsl joined
06:37 k0nsl joined
07:14 ogny1 joined
07:23 kvda joined
07:24 grayhemp joined
07:50 black_ant joined
07:56 magellanic joined
07:57 <magellanic> thanks for the 3.6 docker image to latest :)
08:06 cyborg-one joined
08:07 netmoleCBA joined
08:10 <netmoleCBA> good morning i have question i am installed first time alpine linux and now i cant ssh to it i am installed openssh properly
08:17 Caplain joined
08:25 grayhemp joined
08:25 <jomat> did you start sshd?
08:25 <stevenroose> How do I prevent DHCP from updating resolv.conf in Alpine?
08:25 <jomat> installation only won't start services
08:25 <xentec> netmoleCBA: # rc-update add sshd
08:26 <stevenroose> I read about updating dhclient conf at /etc/dhcp/dhclient.conf, but Alpine doesnt hve that file and doesnt have dhclient
08:26 <stevenroose> (it does have _dhclient, weirdly)
08:26 <netmoleCBA> yes i did
08:31 <netmoleCBA> ssh says access denied any idea why i cant ssh in
08:32 <Bun> stevenroose: https://forum.alpinelinux.org/forum/networking/how-avoid-overwriting-etcresolvconf-dhcp ?
08:32 wuyin joined
08:33 wuyin left
08:34 royger joined
08:37 <stevenroose> Bun that seems helpful! thansk al ot
08:41 lesion joined
09:07 consus joined
09:27 boris joined
09:28 <boris> hello, seems that the alpine 3.6 image for rpi is not booting on my pi3 ...
09:29 <boris> nothing on the screen so it's hard to say what's wrong
09:30 <xentec> boris: how many times does the rpi3 ACT-LED blink in succession?
09:31 <xentec> if it's 7 and you have labeled your FAT partiton, then reformat without the label and try again
09:32 <boris> xentec: 1 time orange blink
09:32 <boris> like with a working boot with v3.5.2
09:51 <boris> same partitions with 3.5.2 and it works
09:52 <Bun> someone else earlier had a similar problem, so maybe it's broken
09:54 <boris> ok :\
09:57 <Bun> maybe you can e.g. try 3.6 without updating the kernel?
10:00 <boris> yes I just need the latest version of docker so I can wait
10:04 <Bun> you can try package pinning if you're desperate
10:13 grayhemp joined
10:21 cyteen joined
11:00 black_ant joined
11:11 grayhemp joined
11:15 Skele joined
11:16 Kruppt joined
11:37 ogny joined
11:42 boris joined
11:47 gromero joined
12:11 grayhemp joined
12:16 fekepp joined
12:17 aw1 joined
12:22 Orochimarufan joined
12:51 dave0x6d joined
13:25 ogres joined
13:28 rdutra joined
13:28 farosas joined
13:40 Marc1n joined
14:02 grayhemp_ joined
14:30 atrigent joined
14:35 aw1 joined
14:42 mwbrown joined
15:08 emacsoma` joined
15:08 manacit joined
15:08 manacit left
15:23 grayhemp joined
15:28 BitL0G1c joined
15:32 vezult joined
15:32 czart joined
15:35 <vezult> Using a script based on these instructions: https://wiki.alpinelinux.org/wiki/Installing_Alpine_Linux_in_a_chroot
15:35 <vezult> I'm seeing ERROR: alpine-baselayout-3.0.4-r0: BAD signature
15:36 <vezult> but just on that package, none of the others
15:36 <vezult> is this a known issue? am I doing something wrong?
15:36 arnotixe joined
15:38 grayhemp joined
15:41 grayhemp joined
15:41 <vezult> to be clear, that's when running: ./sbin/apk.static -X ${mirror}/latest-stable/main -U --allow-untrusted --root ${chroot_dir} --initdb add alpine-base
15:52 atrigent joined
15:53 D630 joined
16:29 luxio joined
16:29 <luxio> I'm not getting image previews in Thunar, I have tumbler installed
16:35 cyborg-one joined
16:50 rivarun joined
17:08 gromero joined
17:16 aw1 joined
17:19 pepan123 joined
17:19 <pepan123> hello
17:20 <pepan123> I would like to build a kernel module under alpine linux, but even after installing linux-headers, there is no build in /lib/modules/<kernel version>, may I ask in which package can I find it?
17:25 gopar joined
17:52 Nobabs27 joined
17:55 grayhemp joined
17:55 lonwillett joined
18:17 dave0x6d joined
18:23 black_ant joined
18:36 grayhemp joined
18:41 grayhemp_ joined
18:42 grayhemp_ joined
18:59 grayhemp joined
19:00 grayhemp joined
19:00 Kruppt joined
19:08 rivarun left
19:12 orbiter joined
19:18 MH0815 joined
19:19 greguu joined
19:21 tmh1999_watcher_ joined
19:30 greguu joined
19:32 sergey_ joined
19:41 gopar joined
19:53 dlaube joined
19:54 pavlix joined
19:54 <pavlix> how are you all?
19:54 <_ikke_> doing okay
19:54 greguu joined
19:56 dlaube joined
20:15 <budric[m]> hi, does alpine come with "useradd" binary that allows specifying password hash on commandline for new user? I'm trying to write some bash scripts to provision a system but can't figure out how to set password for user.
20:19 <ncl> chpasswd?
20:19 <Shiz> yeah, chpasswd is what you want
20:20 <Shiz> echo "username:$crypthash" | chpasswd -e
20:20 <Shiz> should work
20:20 <Shiz> budric[m]: ^
20:21 <vezult> so, just in case someone is now present who knows something about this...I'm building an alpine chroot (https://wiki.alpinelinux.org/wiki/Installing_Alpine_Linux_in_a_chroot)
20:22 <vezult> when I run /sbin/apk.static -X ${mirror}/latest-stable/main -U --allow-untrusted --root ${chroot_dir} --initdb add alpine-base ...
20:22 <vezult> it installs a bunch of base packages
20:22 <vezult> but I get ERROR: alpine-baselayout-3.0.4-r0: BAD signature
20:22 <vezult> only on that one package
20:23 <Shiz> oh dear, i hope dl-cdn isn't having issues again
20:23 <Shiz> vezult: what if you set your mirror to cz.alpinelinux.org/alpine ?
20:23 <vezult> hmm, let me try
20:24 <vezult> that seems to be fine
20:24 <Shiz> thanks for reporting that, seems like dl-cdn has issues then :/
20:25 <vezult> Shiz: thanks
20:25 <Shiz> i've relayed it, hope someone with access will take a look at it asap
20:25 <Shiz> :P
20:47 black_ant joined
21:00 minimalism joined
21:14 dlaube1 joined
21:23 <budric[m]> Shiz: thanks for the suggestion, works great!
21:42 arnotixe joined
21:45 consus joined
22:00 <luxio> is there anything I should know before creating a package for alpine?
22:04 gopar joined
22:07 <Shiz> luxio: there's a page on how to setup your system for building alpine packages
22:08 <Shiz> aside from that, the musl FAQ can be handy if you run into issues
22:08 <Shiz> it addresses some common issues
22:20 Mr_H joined
22:22 gopar joined
22:29 aw1 joined
22:30 aw1 joined
22:53 aw1 joined
22:54 gopar joined
22:54 gopar joined
23:27 aw1 joined