<    April 2017    >
Su Mo Tu We Th Fr Sa  
                   1  
 2  3  4  5  6  7  8  
 9 10 11 12 13 14 15  
16 17 18 19 20 21 22  
23 24 25 26 27 28 29  
30
03:36 <wakatara> adam12: I did change it to update but still having the same error being called. I think the issue is that i have no idea what is causing that problem. Other similarly formed update blocks work, so right now just trying to figure out why update would not be accepting params[:assessments]. LIke I said, I've worked around it so it's working. What I don't like is not knowing why I was getting the
03:36 <wakatara> problem in the first place. I cannot see a reason params[:assessments] wpuld not work and why it would complain it's not a hash.
03:36 <wakatara> (and yes, just for confirmation AR0
03:37 <adam12> Are you a pry user? I'd stick a binding.pry call somewhere near that line and see what params[:assessments] is
03:37 <adam12> and then I would check the model for errors after the update fails.
03:37 <adam12> I think update_attributes is fine, but I believe it skips callbacks, which I thought could be causing an issue.
04:03 <wakatara> adam12: Will check with pry. Thanks...
04:03 <wakatara> (haven't used it in a while to be honest, but used to, so... =] ).
05:15 wikimatze joined
09:11 wikimatze joined
09:30 wikimatze joined
09:39 wikimatze joined
10:02 wikimatze joined
11:39 wikimatze joined
12:26 wikimatze joined
12:34 wikimatze joined
12:55 wikimatze joined
13:04 bvcosta joined
14:24 kuadrosx joined
14:25 kuadrosx_ joined
16:06 kuadrosx joined
19:04 wikimatze joined
19:11 hive-mind joined