<    March 2017    >
Su Mo Tu We Th Fr Sa  
          1  2  3  4  
 5  6  7  8  9 10 11  
12 13 14 15 16 17 18  
19 20 21 22 23 24 25  
26 27 _2_8 29 30 31
00:03 bvcosta joined
00:23 EyePulp joined
00:38 wlightning-fuel joined
00:49 sargas joined
00:56 daxelrod joined
00:58 p1rate joined
00:58 p1rate joined
01:01 Cohedrin joined
01:10 daxelrod1 joined
01:20 Azure joined
01:23 edrocks joined
01:38 daxelrod joined
01:51 hahuang65 joined
01:59 lbtxyz joined
02:31 wlightning-fuel joined
02:41 hphuoc25 joined
02:42 hphuoc25 joined
02:43 hphuoc25 joined
02:54 wlightning-fuel joined
03:14 minimalism joined
03:16 svm_invictvs joined
03:25 EyePulp joined
03:25 edrocks joined
03:33 jon-mac joined
03:34 daxelrod1 joined
03:49 nathans joined
03:49 chipotle joined
03:52 Ruby_Rocks_007 joined
04:05 saurabhjha joined
04:07 hphuoc25 joined
04:14 palinf joined
04:20 hphuoc25 joined
04:22 hphuoc25 joined
04:22 hphuoc25 joined
04:53 RemiFedora joined
04:54 ppang joined
05:24 shlant joined
05:24 <shlant> Hi all. I just noticed that when running a command against one of my redis hosts, it returns "(error) READONLY You can't write against a read only slave." BUT the exit code is 0…. that doesn't seem right
05:25 <shlant> because of that, my Ansible playbook was showing the command as succeeding
05:40 wlightning-fuel joined
06:01 humboldt joined
06:13 rchavik joined
06:26 [1]moteus joined
06:27 edrocks joined
06:31 hphuoc25 joined
06:31 asifm joined
06:36 Cohedrin joined
06:41 saurabhjha joined
06:45 asifm_ joined
06:49 herez joined
07:14 rchavik joined
07:15 EyePulp joined
07:26 hahuang61 joined
07:34 ppang joined
07:40 ppang joined
07:55 chipotle joined
08:03 chen joined
08:11 svm_invictvs joined
08:12 ppang_ joined
08:15 asifm joined
08:19 trueneu joined
08:22 saurabhjha joined
08:24 hphuoc25 joined
08:29 rendar joined
08:37 Jrz joined
08:45 saurabhj_ joined
08:51 asifm joined
08:53 Dave_R joined
08:56 moteus joined
08:58 moteus joined
08:59 soveran joined
09:06 saurabhjha joined
09:07 soveran joined
09:07 chipotle joined
09:29 edrocks joined
09:48 Trevor joined
09:50 <Guest99069> hi, I am confused that tcpdump got nothing when using redis-benchmark
09:50 <Guest99069> but I see the write function call in writeHandler
09:51 <Habbie> maybe redis is using a unix socket?
09:52 <Guest99069> I did not use -s option
09:53 <Habbie> maybe you're dumping the wrong interface
09:54 <Guest99069> At first, I used redis command 'monitor', but got nothing. Then I used tcpdump to monitor, still got nothing.
09:54 rileyy joined
09:54 <Habbie> then you're not talking to the same redis instance ;)
09:54 <Guest99069> What do you mean by 'dumping the wrong interface'?
09:55 <Habbie> you might be running tcpdump on eth0 while redis is talking on lo0
09:56 <Guest99069> when I use redis-cli, both redis cmd 'monitor' and tcpdump worked
09:56 efphe joined
09:56 <Habbie> but redis-benchmark is invisible?
09:57 <Guest99069> invisible
09:57 <Guest99069> can not see any data from tcpdump
09:59 <Guest99069> When I change ip or port when using redis-benchmark, I got 'Writing to socket: Connection refused'. And can see data flowing with tcpdump.
10:00 drbobbeaty joined
10:07 yunlong joined
10:12 saurabhj_ joined
10:22 colo-work joined
10:22 <colo-work> hi there
10:23 <colo-work> we have a number of redis servers configured with AOF, and would like to switch those to do periodic RDB dumps instead. is there a recommended migration path for this, that doesn't involve data loss and as little downtime as possible?
10:34 programmingcool joined
10:49 antonio` joined
10:52 hphuoc25 joined
11:00 humboldt joined
11:02 tomaz_b joined
11:06 Mr__Anderson joined
11:12 soveran joined
11:12 soveran joined
11:21 <badboy_> colo-work: uhm, just enable it on the fly?
11:23 <colo-work> badboy_, ah, I had totally forgotten about setting config options via redis-cli :X
11:23 <colo-work> that makes it kinda obvious, i guess
11:23 <badboy_> don't forget to persist it to the config file afterwards
11:24 <colo-work> yep, sure thing
11:27 <colo-work> thanks :)
11:27 Ruby_Rocks_007 joined
11:39 chipotle joined
11:46 bvcosta joined
11:48 EyePulp joined
11:58 saurabhjha joined
12:00 ppang joined
12:14 soveran joined
12:14 soveran joined
12:17 soveran joined
12:17 soveran joined
12:19 shinnya joined
12:32 edrocks joined
12:33 [1]moteus joined
12:44 rchavik joined
12:47 [1]moteus joined
12:52 pila joined
12:54 drbobbeaty joined
13:03 efphe joined
13:07 [1]moteus joined
13:20 moteus joined
13:26 moteus joined
13:29 edrocks joined
14:04 EyePulp joined
14:11 tomaz_b joined
14:17 cyborg-one joined
14:19 moteus joined
14:19 moteus joined
14:25 Pateriack joined
14:28 shesek joined
14:34 moteus joined
14:43 ogres joined
14:45 bannakaffalatta joined
14:49 daxelrod joined
14:49 amosbird joined
14:53 EyePulp joined
15:28 al-damiri joined
15:50 daxelrod1 joined
15:51 daxelrod2 joined
15:53 cyclones92 joined
15:54 cliluw joined
15:56 minus joined
15:59 daxelrod joined
16:02 cliluw joined
16:06 wlightning-fuel joined
16:07 Ruby_Rocks_007 joined
16:11 saurabhjha joined
16:14 bvcosta joined
16:17 FunnyLookinHat joined
16:23 hahuang61 joined
16:24 cliluw joined
16:37 forgotmynick joined
16:40 hahuang65 joined
16:41 forgotmynick joined
16:42 tristans joined
16:44 cliluw joined
16:51 tristans joined
17:01 svm_invictvs joined
17:04 forgotmynick joined
17:04 forgotmynick joined
17:12 trueneu joined
17:23 edrocks joined
17:34 minimalism joined
17:38 toncek55 joined
17:42 svm_invictvs joined
17:46 sargas joined
17:48 FatDarrel joined
17:55 cliluw joined
17:55 BatteryStaple joined
18:22 cyborg-one joined
18:27 hahuang65 joined
18:28 Cohedrin joined
18:35 gabe__ joined
18:36 <gabe__> Hello everyone, I'm having problems starting my redis cluster on my mac, it used to work but not it gives this error: Sorry, the cluster configuration file nodes.conf is already used by a different Redis Cluster node. Please make sure that different nodes use different cluster configuration files.
18:36 <gabe__> I posted on stack overflow with more info here: http://stackoverflow.com/questions/42642070/unable-to-start-redis-cluster-servers
18:36 <gabe__> Thanks!
18:38 <gabe__> *but now it gives this
18:40 wlightning-fuel joined
18:43 soveran joined
18:43 saurabhjha joined
18:49 svm_invictvs joined
18:53 daxelrod1 joined
18:59 asifm joined
19:11 <BatteryStaple> @gabe__ you can run many redis clusters on a single host. Each instance must bind to a differnt port and utilize a different configuration filename.
19:12 saurabhjha joined
19:13 <BatteryStaple> @gabe__ chances are something updated a nodes.conf file on your system
19:13 akkad joined
19:13 <minus> if it crashed before there might still be some lock file, who knows
19:17 pila joined
19:21 asifm_ joined
19:35 akkad joined
19:39 timg__ joined
19:40 asifm_ joined
19:44 <gabe__> Thanks @BatteryStaple
19:44 <gabe__> looks like a nodes.conf is being generated from whereever I call redis-server from
19:44 <gabe__> and that may be the culprit
19:45 <gabe__> i had a script that just ran redis-server with an absolute path argument to each of the different redis.conf files
19:45 <gabe__> so looks like i actually have to 'cd' into each directory before i can call and start the servers?
19:47 saurabhj_ joined
19:48 daxelrod joined
19:52 cyborg-one joined
19:55 tgodar joined
19:56 JagArLedsen joined
19:58 cliluw joined
20:04 tomaz_b joined
20:07 FatDarrel_ joined
20:13 asifm_ joined
20:18 asifm_ joined
20:21 bvcosta joined
20:25 daxelrod joined
20:46 soveran joined
20:58 rendar joined
20:58 rendar joined
20:59 wlightning-fuel joined
21:03 FatDarrel joined
21:14 daxelrod joined
21:22 daxelrod1 joined
21:32 asifm left
21:32 Mr__Anderson joined
21:43 trueneu joined
21:48 Azure|dc joined
21:58 Dabo joined
21:58 dblessing joined
22:00 <dblessing> Can anyone think of a reason for this error: `ERR unknown command '<86>Dec'`? It seems to only affect Debian 7 and 8 users.
22:00 <dblessing> Such a strange string. I have no idea where it came from and why it would have been passed to Redis as a command.
22:02 FatDarrel joined
22:04 tgodar joined
22:18 shinnya joined
22:24 JagArLedsen joined
22:31 soveran joined
22:31 soveran joined
22:34 chipotle joined
22:38 daxelrod joined
22:41 bvcosta joined
22:43 daxelrod joined
22:47 ogres joined
22:59 soveran joined
22:59 soveran joined
23:13 bannakaffalatta joined
23:14 trueneu joined
23:16 cliluw joined
23:17 hahuang65 joined
23:21 ahfeel joined
23:22 vincent_ joined
23:25 FatDarrel joined
23:28 minus joined
23:32 minus joined
23:51 p1rate joined
23:51 p1rate joined