<     May 2017     >
Su Mo Tu We Th Fr Sa  
    1  2  3  4  5  6  
 7  8  9 10 11 12 13  
14 15 16 17 18 19 20  
21 22 23 24 25 26 27  
28 29 30 31
00:03 dumbitguy_ joined
00:03 djinni joined
00:26 TheFuzzball joined
00:38 linux_dr joined
00:43 <linux_dr> anyone seen NFS inconsistancies between mac and linux host machines?
00:45 d^sh joined
01:02 cqi joined
01:04 dumbitguy_ joined
01:10 bannakaffalatta joined
01:38 k0nsl_ joined
01:44 jalokia joined
01:48 Wanderer- joined
01:49 Wanderer- joined
01:51 dbclk_ joined
01:54 d^sh_ joined
01:58 balazs joined
02:01 zerocoolback joined
02:04 cqi joined
02:27 notdaniel joined
02:41 wlightning-fuel joined
03:00 d^sh joined
03:10 wlightning-fuel joined
03:26 dbclk joined
03:28 jeffreylevesque joined
03:53 <double-p> glurp: just compare 'vagrant landrush ls' and guests resolv.conf ('search')
04:03 <glurp> double-p: I finally figured out my issue (about 5 minutes ago). It was related to this issue: https://github.com/vagrant-landrush/landrush/issues/295
04:03 <glurp> basically the landrush dns redirector server was not being started
04:04 <glurp> because there was a path change in vagrant 1.9.0+
04:04 <glurp> so I symlinked the paths and the landrush server started up and boom, there we go
04:24 viniciusfs joined
04:24 notdaniel joined
04:41 jeffreylevesque_ joined
04:41 <double-p> oh, had a "fresh" install with 1.9 so didnt notive
05:03 cqi joined
05:15 budhram joined
05:47 Specialist joined
06:01 notdaniel joined
06:08 budhram joined
06:35 druonysus joined
06:47 `brian joined
06:54 techquila joined
06:55 serque joined
07:04 TomyWork joined
07:05 memoryleak joined
07:07 indistylo joined
07:07 techquila joined
07:10 Wanderer- joined
07:17 dkh joined
07:28 _KaszpiR_ joined
07:32 overbythere joined
07:33 atomekk joined
07:33 atomekk joined
07:43 zerocoolback joined
07:52 Specialist joined
07:56 marcogmonteiro joined
08:06 Orion3k joined
08:14 _ADN_ joined
08:16 cloudbud joined
08:16 <cloudbud> how to set up password less authentication in vagrant
08:21 vj3k joined
08:24 <absolutejam> I think the standard method is to create a 'vagrant' user
08:25 <absolutejam> and then use the Vagrant key (on github)
08:25 <absolutejam> Anyone have any ideas about my Vagrantfile issue from yesterday?
08:27 <double-p> absolutejam: that unless line doesnt need a 'do' to enter the loop?
08:28 <double-p> i think it just doesnt anything with that line. and the next one is indented, but taken every time anyway [guesswork]
08:30 zerocoolback joined
08:32 _ADN_ joined
08:33 budhram joined
08:36 glurp joined
08:38 _ADN_ joined
08:40 antgel joined
08:44 cstratak joined
08:50 Kug3lis joined
08:51 budhram_afk joined
08:58 electrofelix joined
09:04 Natrick joined
09:05 xaver joined
09:09 TheFuzzball joined
09:13 overbythere joined
09:16 howitdo joined
09:17 csotelo joined
09:28 TheFuzzball joined
09:34 cstratak joined
09:41 techquila joined
09:46 zofrex joined
09:57 Orion3k joined
09:57 notdaniel joined
10:01 serque joined
10:15 budhram joined
10:21 budhram joined
10:22 oshabrz joined
10:32 budhram joined
10:36 notebox joined
10:56 nicolasbock joined
11:05 cstratak joined
11:09 TheFuzzball joined
11:12 Specialist joined
11:15 atomekk joined
11:15 atomekk joined
11:39 livingstn joined
11:41 gbt joined
11:57 budhram_ joined
12:09 computeracer joined
12:12 <absolutejam> hm, I don't think so
12:19 ogny joined
12:21 TsunamiFoodTarge joined
12:26 TsunamiFoodTarge joined
12:29 caper joined
12:30 cqi joined
12:31 zerocoolback joined
12:45 zerocoolback joined
12:51 jeffreylevesque joined
12:56 celsosantos joined
12:57 TheFuzzball joined
13:01 livingstn joined
13:02 jayunit100 joined
13:03 livingstn joined
13:10 memoryleak joined
13:24 nZac joined
13:33 dbclk joined
13:38 glurp left
13:39 pgdagenais joined
13:46 charginghawk joined
13:46 oshabrz joined
13:47 dumbitguy_ joined
13:47 serque joined
13:52 overbythere joined
13:53 wlightning-fuel joined
13:57 bannakaffalatta joined
14:05 vj3k joined
14:08 livingstn joined
14:16 dxtr joined
14:19 dxtr joined
14:24 Seablade_pixel joined
14:28 wlightning-fuel joined
14:30 bilal joined
14:31 jerematic joined
14:38 Stacie_A joined
14:38 gbt_ joined
14:39 ntnn joined
14:43 notebox joined
14:46 ntnn joined
14:49 indistylo joined
14:56 pgdagenais joined
14:57 elsevero joined
15:01 ueberall joined
15:03 wlightning-fuel joined
15:04 TheFuzzb_ joined
15:07 TsunamiFoodTarg1 joined
15:17 bilal_ joined
15:20 bilal__ joined
15:35 TsunamiFoodTarge joined
15:42 budhram joined
15:44 Faulkner joined
15:50 bilal joined
15:54 ij left
15:56 cstratak joined
15:57 cstratak joined
15:57 bilal joined
16:03 bilal joined
16:04 budhram joined
16:04 wlightning-fuel joined
16:25 qba73 joined
16:32 bilal joined
16:51 Kug3lis joined
16:55 livingstn joined
17:04 Davey joined
17:04 Davey joined
17:22 nshaikh joined
17:25 nZac joined
17:27 dbclk joined
17:30 gmoney joined
17:44 DogHackit_ joined
17:46 nZac joined
17:49 yhchiang joined
17:50 yhchiang joined
17:55 nZac joined
17:55 elsevero joined
17:57 raynold joined
18:05 Edgan joined
18:10 nZac joined
18:20 livingst_ joined
18:27 notdaniel joined
18:43 dlam joined
18:44 <dlam> anyone know why this gives me the error "One of `path` or `inline` must be set."? i like copied this straight from the docs: config.vm.provision "shell", inline: $SYM_LINK_GUEST_ADDITIONS
18:44 <* dlam> dosent know ruby
18:48 vagrant088 joined
18:48 TsunamiFoodTarge joined
18:50 yhchiang joined
18:51 yhchiang_ joined
18:52 kpease joined
18:53 notebox joined
18:56 puppy joined
18:57 <puppy> any recommendations on a good guide for setting up mongodb in a vagrant box?
19:00 notdaniel joined
19:07 aswen joined
19:13 TsunamiFoodTarge joined
19:24 <spox> dlam: my best guess is that the variable does not have a value
19:41 vj3k joined
19:58 _ADN_ joined
20:16 kpease joined
20:16 nalum joined
20:26 kpease joined
20:33 <absolutejam> alright, I'm losing the will to live
20:33 <dlam> ooo thanks spox, maybe i defined it wrong
20:33 <absolutejam> Not sure if Ruby, Vagrant or me is stupid
20:33 <absolutejam> Thinking the last option
20:34 <absolutejam> https://pastebin.com/GBaCgT4H
20:34 <absolutejam> surely that should just `put` both disk names?
20:35 <absolutejam> But I'm getting both of them 6 times each!
20:38 <spox> absolutejam: it's because the file is evaluated multiple times during the run
20:39 <absolutejam> but
20:39 <absolutejam> but
20:39 <absolutejam> ugh
20:40 <absolutejam> how can I reasonably provision a number of disks ONCE in my Vagrantfile?
20:40 <absolutejam> Maybe it's multiple issues.
20:40 <spox> the way you have it setup it _would_ if it were creating those things
20:40 <spox> since it's not, you're always getting the puts
20:41 <absolutejam> If the file does NOT exist, create it - Right?
20:41 <absolutejam> I mean, my logic
20:41 <absolutejam> I don't know Ruby, but I'm trying to tackle it for this
20:43 <spox> yeah, you can test it out easy enough. after your puts on like 19 add this: FileUtils.mkdir_p("disks"); FileUtils.touch(disk_path)
20:45 <absolutejam> ugh, why does that work but mine not work?
20:45 <absolutejam> Does the Virtualbox part get done last?
20:46 nalum joined
20:46 <spox> i'm not sure what you mean? are you asking why it works when you add what i gave you?
20:46 <absolutejam> yeah
20:46 <absolutejam> surely the vb.customize line should be creating the disk
20:47 <absolutejam> and therefore validating the File.exists? part
20:48 <spox> just because the code is being evaluated doesn't mean the configuration it's providing is for that specific task being performed
20:49 <spox> it might be easier to just destroy the array when you setup
20:49 <spox> then it can only be looped through once
20:50 <spox> until(shared_disks.empty?); disk = shared_disks.pop; ... do config stuff ... end;
20:52 nalum joined
20:53 <absolutejam> hm, that makes sense
20:53 <absolutejam> So is the issue I'm facing just an issue in the way that Vagrant parses the config file?
20:53 <absolutejam> or an imcompatibility should I say
20:54 <spox> right. it loads the file multiple times, causing the code to be executed multiple times. it won't have any impact on the functionality you're trying to obtain. it just prints the message more times than you're expecting
20:56 nalum joined
20:57 vj3k joined
21:00 <absolutejam> I think it was more the issue with virtualbox not creating the disk while it was being processed by File.exists?
21:01 <absolutejam> But I guess that could come later; I'm not sure
21:01 pizzaOfDoom joined
21:07 caper joined
21:10 caper joined
21:20 indistylo joined
21:20 <spox> absolutejam: when the vagrantfile is loaded and that line is evaluated, it does not immediately create the disk, it simply adds it to the configuration for when the action is actually performed
21:21 <spox> i think that might be the disconnect of what's actually happening within vagrant, and the expectation of what's happening
21:26 linux_dr joined
21:30 <linux_dr> Hmm… back again today… two identical guest VMs: one on Linux other on Mac… both mounting project directory via NFS… except “rsize” and “wsize” all meaningful NFS parameters look identical… Linux host is causing guest to fail on flock while Mac host allows guest to flock with no error reported. “local_lock” on both guests is set to “none”…. am I missing something?
21:31 <linux_dr> (NFS parameters as reported by “mount”)
21:36 <spox> can you post the folder line from your vagrantfile?
21:49 jeffreylevesque joined
22:02 <linux_dr> spox: It’s a scripting mess, but I’ll see what I can do
22:38 nZac_ joined
23:09 dumbitguy_ joined
23:41 yhchiang joined
23:41 k0nsl joined
23:41 k0nsl joined
23:42 caper joined